Back to overview
Degraded

Slowdown while recovering

Jul 18 at 09:06am PDT
Affected services
Web App (app.withvector.com)
Core Services (API Requests)

Resolved
Jul 18 at 09:44am PDT

All services should be running normal at this time

Created
Jul 18 at 09:06am PDT

Some Vector services may be degraded due to an issue with Google Cloud Services. We are seeing that they are beginning to recover, and we are continuing to process anything that was stalled during Google's service degradation period