Investigating slowdown
Resolved
Sep 04 at 12:16pm PDT
We’ve identified the root cause of the issue and deployed a fix. System performance has since stabilized and should now be back to normal. We truly appreciate your patience and partnership as we worked to resolve this.
Affected services
Updated
Sep 04 at 11:45am PDT
Systems are recovering and performance is improving. Some residual slowness may remain as we catch up. Our team is continuing to monitor closely. Thank you for your patience.
Affected services
Created
Sep 04 at 09:09am PDT
We are currently investigating reports of degraded performance. Our engineering team is actively working to investigate and implement a solution. We will provide an update as soon as more information becomes available.
Thank you for your patience.
Affected services