Back to overview
Degraded

Anomalies with check-in data visibility

Mar 30, 2026 at 6:19pm UTC
Affected services
Web App (app.withvector.com)
Core Services (API Requests)
Mobile Web (m.withvector.com)

Resolved
Mar 31, 2026 at 4:40pm UTC

Service returned to normal: Services were restored and affected customers confirmed check-in data was displaying correctly shortly after the 9:40 AM ET configuration change.

Updated
Mar 31, 2026 at 4:35pm UTC

Fix pushed: The successful fix was implemented by disabling (rolling back) the document thinning feature.

Updated
Mar 31, 2026 at 2:25pm UTC

Root cause identification and issue: The root cause was identified as an Elasticsearch configuration change for document thinning that produced unintended side effects in the search and data retrieval layer.

Created
Mar 30, 2026 at 6:19pm UTC

  • Disappearing check-ins: Records that existed in the system were not returned in the check-in view.
  • Duplicate entries: The same check-in record appeared multiple times in the list view.
  • Inaccurate counts: The bubble count indicators shown in the interface did not match the actual number of rows displayed.