Back to overview

RESOLVED - Major delays

Jun 1, 2026 at 3:10pm UTC
Affected services
Web App (app.withvector.com)
Core Services (API Requests)
Mobile Web (m.withvector.com)
SFTP Server

Resolved
Jun 1, 2026 at 3:10pm UTC

We are seeing full recovery; the incident is resolved.