Back to overview

Server recovery - minor delays

Jun 12, 2026 at 1:05pm UTC
Affected services
Web App (app.withvector.com)
Core Services (API Requests)
Mobile Web (m.withvector.com)
SFTP Server

Resolved
Jun 12, 2026 at 5:07pm UTC

Our servers have fully recovered and all services have been restored.

Updated
Jun 12, 2026 at 3:59pm UTC

We are seeing system recovery across services and are monitoring for stability.

Created
Jun 12, 2026 at 1:05pm UTC

System recovery update - functionality restored with minor delays. Our engineers are aware of an issue impacting server connection and actively investigating. We will provide an update on the hour.